Sunday, June 14, 2009

Windows Server 2003 SP2 Setup Fails - WMI Error

When installing service pack 2, the setup crashed and errored out.

This is what I got in my svcpack.log file located in C:\windows

650.266: Return Code = 0
650.266: Starting process: rundll32 apphelp,ShimFlushCache
650.313: Return Code = 0
650.313: Starting process: C:\WINDOWS\system32\wbem\mofcomp.exe C:\WINDOWS\system32\wbem\wlbsprov.mof
650.578: Return Code = 3
650.578: Starting process: C:\WINDOWS\system32\wbem\mofcomp.exe C:\WINDOWS\system32\wbem\cimwin32.mof
651.313: Return Code = 3
651.313: DoInstallation:RunInfProcesses for ProcessesToRun Failed
651.313: Service Pack 2 Setup encountered an error: An error in updating your system has occurred.
657.703: Unregistration of sprecovr successful
658.266: An error in updating your system has occurred.

Select 'OK' to undo the changes that have been made.
665.328: Message displayed to the user: An error in updating your system has occurred.

Select 'OK' to undo the changes that have been made.
665.328: User Input: OK

After a bit of research I came accross this website by someone named Katy that showed my exact error, and showed that it was related to WMI problems:

http://www.djkaty.com/wmicorruption

This is a brilliant artical I suggest you have a read. My problem was a little bit different to Katy's. My WMI service didnt even exist!



When I went to the WMI control properties in computer management I got the following:



To get this back I ran the following in command prompt:

wmimgmt /regserver

This got the service back:



Setup then completed successfully.

1 comment:

  1. Nice and very helpful information i have got from your post. Even your whole blog is full of interesting information which is the great sign of a great blogger.

    Lenovo - ThinkPad Helix Ultrabook Convertible 11.6" Touch-Screen Laptop - 4GB Memory

    Lenovo - ThinkPad T430 14" Laptop - 4GB Memory - 500GB Hard Drive - Black

    ReplyDelete