Thursday, October 24, 2013

Error Starting WDS Service on SCCM 2012 SP1 Server

I ran into an issue where I was unable to start the WDS service on a newly installed SCCM 2012 SP1 server running on Windows Server 2012.  The following errors were experienced in the application log on the SCCM 2012 distribution point server.

Log Name:      Application
Source:        WDSServer
Date:          25/10/2013 12:30:44 PM
Event ID:      257
Task Category: WDSServer
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      sccm2012.domain.internal
Description:
An error occurred while trying to start the Windows Deployment Services server.

 Error Information: 0x906



Log Name:      Application
Source:        WDSMC
Date:          25/10/2013 12:30:45 PM
Event ID:      594
Task Category: WDS Multicast Server
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      sccm2012.domain.internal
Description:
The Content Provider WDSBOOT loaded from C:\Windows\system32\wdsbcp.dll failed to initialize.
 

Error Information: 0x906


Log Name:      Application
Source:        WDSMC
Date:          25/10/2013 12:30:45 PM
Event ID:      603
Task Category: WDS Multicast Server
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      sccm2012.domain.internal
Description:
The Content Provider WDSBOOT failed to initialize. The provider is marked as critical. WDS Multicast server will fail to start.

 Error Information: 0x906



Log Name:      Application
Source:        WDSServer
Date:          25/10/2013 12:30:45 PM
Event ID:      513
Task Category: WDSServer
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      sccm2012.domain.internal
Description:
An error occurred while trying to initialize provider WDSMC from C:\Windows\system32\wdsmc.dll. Windows Deployment Services server will be shutdown.

 Error Information: 0x906



This was resolved by initialising the WDS server using the following command.  Generally WDS automatically initialises itself however for an unknown reason on this SCCM server it did not initialise as expected.

 

7 comments:

  1. Thanks,
    This post help me to solve a similar problem

    ReplyDelete
  2. Thanks a lot mate!!!

    ReplyDelete
  3. Up until yesterday my WDS was working perfectly fine. Right up until I went to ad another boot image which kept failing. Eventually I decided to re-initialize the server so after un-initializing and then initializing, I get error code 0x7B ; the filename, directory name, or volume label syntax is incorrect.

    The service wont start either...all other services are ok. Any ideas?

    Cheers,

    Aaron

    ReplyDelete
  4. IT Staff outsourcing services First of all, it is a risk of information leak. Each company which performs outsourcing IT services guarantees confidentiality, thus this risk is minimal but still it happens to be. Another unpleasant probable situation is a bankruptcy of the chosen company which provides you with software outsourcing services, thus you will have to look for another one and to start all over again.

    ReplyDelete